
After completing this unit, you should understand the following:

HTML basics

How to create an HTML document

How to add headings
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The Basics
It’s time to create a sample HTML document. Finally! First we’ll
practice the basics. Once you’ve learned about the tags, you’ll
read more theory about good Web page design. Then you can
start designing your own personal page.

Begin at the Beginning
Every HTML document starts with an <HTML> start tag and
ends with an </HTML> end tag. These two tags identify the text
between them as HTML formatted. Everything you type from
here on will be nested inside this tag pair.

You can’t add white space to an HTML document by press-
ing the spacebar, pressing t, or adding blank lines. HTML
doesn’t recognize white space unless it’s in a preformatted
paragraph. (<PRE> tags are discussed later in the book.)

Inside the <HTML>...</HTML> tag pair is the
<HEAD>...</HEAD> pair and then the <BODY>...</BODY> pair.
The <HEAD> and <BODY> tag pairs effectively divide the docu-
ment into two sections: the heading and the body.

Head and Title: The <HEAD>...</HEAD> tag pair can include a
variety of optional information, which we’ll go into later. For
now, the most important element in the <HEAD> tag pair is
the <TITLE>  tag for your page. The title is important
because search tools often index pages by their titles. The
title should be short and descriptive of the page content.
(For example, “Northwest Dogs Home Page” is more

NO ROOM FOR MISTAKESNO ROOM FOR MISTAKESNO ROOM FOR MISTAKESNO ROOM FOR MISTAKESNO ROOM FOR MISTAKES

HTML is an unforgiving language.

Typographical errors will often render a tag

invisible to the browser. Some HTML editors

include built-in error-checking logic that

doesn’t allow you to save a document

containing formatting mistakes. Shareware

HTML verification programs are also

available online. (Weblint is a good one for

the PC.) Regardless, type carefully and check

for typos. If you don’t catch them in the text

editor, you’ll certainly see them when you

view the page in a browser window.
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descriptive than “Dogs.”) Often the
title matches the first heading in the
body of the document. If your page is
part of a multipage site, the title
should also include a site identifier.
(For example, “Northwest Dogs:
Grooming Huskies.”) Though the title
doesn’t usually display on the Web
page itself, browsers often display it
in a separate text box or include it as
part of the window’s title.

Body: The <BODY>...</BODY> tag pair
includes all other elements: headings,
paragraphs, lists, graphics, links—you
name it.

The structure of these tags never
changes. It’s the first thing you type when
you create a Web page. (In some HTML
editors, these tags are automatically
entered when you create a new docu-
ment.) In most second and third genera-
tion HTML editors (and by second and
third generation we are talking about
products such as Adobe PageMill and
Macromedia Dreamweaver), much of the

HTML coding is done for you. The
problem with these programs is that they
also include many proprietary tags that
many browsers may not recognize. The
format for an HTML document is as
follows:
<HTML>

<HEAD>

<TITLE> document title </TITLE>

</HEAD>

<BODY>

headings, paragraphs, links,

graphics, lists, and so on

</BODY>

</HTML>

Let’s see how this looks on the screen
and add a title.

1. If the following tags aren’t already
entered, click the New button or
choose New from the File menu. If
you’re not using an editor that inserts
these tags automatically, type them as
follows:
<HTML>

<HEAD>
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<TITLE></TITLE>

</HEAD>

<BODY>

</BODY>

</HTML>

Important: Some default HTML documents contain a
<!DOCTYPE HTML PUBLIC "-//IETF/DTD HTML

3.0//EN" "HTML.dtd">  tag above the <HTML> start tag. This
is a comment and will not display in the browser. It exists for
information purposes only and is not currently required.

2. Type The Dog Page inside the <TITLE> ...</TITLE>  tag
pair.
<HTML>

<HEAD>

<TITLE> The Dog Page </TITLE>

</HEAD>

<BODY>

</BODY>

</HTML>

Note: Because HTML doesn’t recognize or care about line
breaks and blank lines (unless they’re so tagged), the document
entered as a continuous string of text is also perfectly legal (but
harder to edit). The example above can be entered as follows:
<HTML><HEAD><TITLE>The Dog Page</TITLE></HEAD>

<BODY></BODY></HTML>

ADDING COMMENTSADDING COMMENTSADDING COMMENTSADDING COMMENTSADDING COMMENTS

Comments can be typed inside a comment

tag, <!-- comment text here --> ,

and inserted anywhere in an HTML

document. You must include a space after

the initial <!--  and preceding the --> .

Avoid placing HTML tags inside of comment

brackets because the extra angle brackets

can confuse some browsers.

Good:

<!-- updated September 5 -->

<!-- Each comment must have its

own start and end comment tags.

-->

Bad:

<!-- Ozzie says to change the

tag to <UL> but I disagree -->

<!-- Each comment must have its

own start and end comment

tags.<BR> -->
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Adding Headings and
Paragraphs
Headings and paragraphs are all inside
the <BODY> of the page. When you
specify a heading or a paragraph, you are
indicating a structural element. The
browser software determines the appear-

FIGURE 2-1   Headings in Netscape Navigator

ance. If you press e to insert blank
lines between headings and paragraphs,
the browser will ignore them. Use blank
lines to enhance the readability of the
HTML file itself, but don’t expect them to
show up in the browser window.

Adding Headings

There are six levels of HTML headings.
Each heading is indicated by a tag pair
numbered H1 through H6 as follows:
<H1>level 1 heading text </H1>

<H2>level 2 heading text </H2>

<H3>level 3 heading text </H3>

<H4>level 4 heading text </H4>

<H5>level 5 heading text </H5>

<H6>level 6 heading text </H6>

Heading levels are differentiated from
each other and the paragraph text by
typeface, point size, and extra space
above or below the elements. As with all
tag pairs, if you don’t include the end tag
(/ ), the browser will think that the subse-
quent text is formatted as part of the same
heading.

In Netscape Navigator, the six levels
of headings look like Figure 2-1.
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Add a level 1 heading to your new
document:

3. Type the following level 1 heading
into your document.
<HTML>

<HEAD>

<TITLE>The Dog Page</TITLE>

</HEAD>

<BODY>

<H1>THE DOG PAGE</H1>

</BODY>

</HTML>

Adding Paragraphs

Paragraph tags are <P> and, optionally,
</P> . As with heading text, paragraph
text looks different from browser to
browser. Typically, paragraphs are not
indented, and a single blank line is
inserted between them. The format is as
follows:
<P>paragraph text

or
<P>paragraph text </P>

<P> tags cannot include heading tags,
but they can include links and various

forms of styles (covered later in this
book). Currently, a closing </P>  tag isn’t
required in standard HTML, but rumor
has it that it may become standard in later
versions. Some browsers do allow modifi-
cation of <P> tags, necessitating a closing
</P> . </P>  tags are sometimes used to
add a little extra white space between
paragraphs.

4. Add the following paragraph text to
your document.
<HTML>

<HEAD>

<TITLE>The Dog Page</TITLE>

</HEAD>

<BODY>

<H1>THE DOG PAGE</H1>

<P>Dogs are fascinating

animals. So are cats and

iguanas; but this is a dog

page, not a cat and iguana

page.

</BODY>

</HTML>
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Saving the Document
In most cases, you must save an HTML document before you
can view it in the browser. The Save function is standardized in
most software. (It’s a good idea to save all of your Web site files
in a single directory for easy referencing. More information on
file organization will be presented later.)

Note: Some HTML editors contain a Preview feature that
launches the browser specified in the Options dialog box and
displays a temporary version of the current document. But the
Preview feature doesn’t work with all browsers. Instead of using
Preview, we’ll save the document when we’re ready to view it,
and use the Reload button in Netscape Navigator to display the
updated file.

Save the document on Drive A.

5. Select Save (usually located in the File menu).

6. Insert your student diskette into Drive A.

7. Name the file a:\doghome.htm.

8. Click OK.

Viewing the Document
As you create your Web page, you should view it frequently
in the browser window. This helps you catch mistakes early in
the game, before the page gets too complicated. If possible,
keep the editor and the browser open so you can switch

FILE NAMES—UNIX, PC, OR MAC?FILE NAMES—UNIX, PC, OR MAC?FILE NAMES—UNIX, PC, OR MAC?FILE NAMES—UNIX, PC, OR MAC?FILE NAMES—UNIX, PC, OR MAC?

More than likely, your published Web site

will be run on a Unix machine. Considering

this, there are a few simple naming

conventions to follow:

Use the file naming convention of the

target server right from the start. This will

save you from having to change file names

prior to uploading the site to the server. If

you don’t know the convention, use the

DOS/Unix file naming convention described

below. This is sometimes referred to as the

8.3 naming convention.

If you’re working on a PC, give your

files a .htm extension. If you’re working on

Unix, give your files a .html extension. Other

extensions such as .shtml exist, but we’ll

stick with the basics for now.

Because Unix file names are case

sensitive (Doghome.htm and doghome.htm

are two different files), choose a case

preference—upper, lower, or mixed—and

stick with it.
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between them as necessary. (Use the
a + t key combination to easily
alternate between the two.)

Viewing the Finished Web Page

To view the Web page as it’ll appear on
the Web, launch your browser and open
the local HTML document you just
created. This is known as opening a local
file, because you’re not going online to
access it.

Open the file as a local document.

1. If necessary, launch the browser.

2. Open your local HTML document,
a:\doghome.htm. In Netscape Navi-
gator, click File, click Open Page, and
select the file. Correctly formatted, the
page should resemble Figure 2-2.

FIGURE 2-2   The Dog Page—Version 1

If your screen doesn’t match the
figure, return to the editor and check that
all your tag pairs are closed properly and
typed correctly. Save the document and
then view the updated version by select-
ing the Reload button in the browser.

Viewing the Document Source

The source is simply the HTML text file
with all the codes revealed. Remember
what you typed in your editor? That’s the
source. Most browsers let you view the
HTML source for any Web document you
display. This is useful because you can
study how other Web pages are struc-
tured.

Browsers usually contain a View Page
Source command. In Netscape Navigator,
choose Page Source from the View menu
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to display the source of the currently
displayed Web page.

Open a document source window to
view the doghome.htm HTML file.

1. With doghome.htm currently dis-
played in your browser, choose Page
Source on the View menu to display
the source code.

FIGURE 2-3   The Dog Page—The Document Source

more paragraph text. When you view the
document in the browser, notice the font
differences among the heading levels.

Insert level 2 and level 3 headings into
the document as follows:

1. Switch to the HTML editor window
(which should still contain
doghome.htm) and add the following
text:
<HTML>

<HEAD>

<TITLE>The Dog Page</TITLE>

</HEAD>

<BODY>

<H1>THE DOG PAGE</H1>

<P>Dogs are fascinating

animals. So are cats and

iguanas; but this is a dog

page, not a cat and iguana

page.

<H2>The most popular dog

breeds</H2>

<P>According to Sleeping

Dogs, Inc., the most popular

dog breeds are terriers,

retrievers, bulldogs,

2. Click the Close button at the upper-
right corner of the window to close it
and return to the browser.

Adding Level 2 and 3 Headings
Let’s beef up doghome.htm by adding a
level 2 heading (<H2>...</H2> ), a couple
of level 3 headings (<H3>...</H3> ), and
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collies, and poodles.

<H3>My favorite dog</H3>

<P>My favorite dog is

Herman, a silly looking mutt

with the body of a golden

retriever and the legs of a

basset hound.

<H3>Mom's favorite dog</H3>

<P>Mom's favorite dog is

Sam, a sweet, hairy, little

sheltie. Unfortunately, Sam

is no longer with us.

</BODY>

</HTML>

2. Save a:\doghome.htm.

3. Switch to the browser window. In the
browser, click Reload or select Open
Page from the File menu (or execute
an equivalent command) to reload the
updated doghome.htm. The page
should resemble Figure 2-4.

FIGURE 2-4   The Dog Page—Version 2
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Skills Check
1. The <HTML> tag tells the browser

a. nothing.
b. the name of the file.
c. how to interpret the document.
d. where to enter text.

2. Which tag pair is used to create the
smallest heading?
a. <H1> </H1>

b. <H1> <\H1>

c. <HS> </HS>

d. <H6> </H6>

3. Which tag is used for creating a new
paragraph?
a. <PARAGRAPH>

b. <PARA>

c. <P>

d. <NEW>

4. Which tag pair contains all the
information that is displayed?
a. <HTML> </HTML>

b. <P> </P>

c. <SECTION> </SECTION>

d. <BODY> </BODY>

5. Which tag identifies a comment in
HTML?
a. <?-->

b. </-->

c. <@-->

d. <!-->
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